• 注册
  • 查看作者
    • Vue CLI 是一个基于 Vue.js 进行快速开发的完整系统

      安装#

      关于旧版本

      Vue CLI 的包名称由 vue-cli 改成了 @vue/cli。 如果你已经全局安装了旧版本的 vue-cli(1.x 或 2.x),你需要先通过 npm uninstall vue-cli -g 或 yarn global remove vue-cli 卸载它。

      Node 版本要求

      Vue CLI 4.x 需要 Node.js v8.9 或更高版本 (推荐 v10 以上)。你可以使用 nnvm 或 nvm-windows 在同一台电脑中管理多个 Node 版本。

      可以使用下列任一命令安装这个新的包:

      npm install -g @vue/cli# ORyarn global add @vue/cli

      安装之后,你就可以在命令行中访问 vue 命令。你可以通过简单运行 vue,看看是否展示出了一份所有可用命令的帮助信息,来验证它是否安装成功。

      你还可以用这个命令来检查其版本是否正确:

      vue --version

      升级#

      如需升级全局的 Vue CLI 包,请运行:

      npm update -g @vue/cli# 或者yarn global upgrade --latest @vue/cli

      项目依赖#

      上面列出来的命令是用于升级全局的 Vue CLI。如需升级项目中的 Vue CLI 相关模块(以 @vue/cli-plugin- 或 vue-cli-plugin- 开头),请在项目目录下运行 vue upgrade

      用法: upgrade [options] [plugin-name]
      
      (试用)升级 Vue CLI 服务及插件
      
      选项:
        -t, --to <version>    升级 <plugin-name> 到指定的版本
        -f, --from <version>  跳过本地版本检测,默认插件是从此处指定的版本升级上来
        -r, --registry <url>  使用指定的 registry 地址安装依赖
        --all                 升级所有的插件
        --next                检查插件新版本时,包括 alpha/beta/rc 版本在内
        -h, --help            输出帮助内容

    • 0
    • 0
    • 0
    • 577
    • 请登录之后再进行评论

      登录
    • 任务
    • 动态
    • 单栏布局 侧栏位置: